Cette page présente l’historique des versions de Show Control Editor, ainsi que les principales caractéristiques du logiciel, la configuration requise, les informations d’installation et les problèmes connus.
TABLE DES MATIÈRES
- Show Control Editor 2.5.1.0
- Show Control Editor 2.5.0.1
- Show Control Editor 2.5.0.0
- Show Control Editor 2.4.0.1
- Show Control Editor 2.4.0.0
- Archives
- Caractéristiques principales
- Configuration requise
- Installation
- Problèmes connus
Show Control Editor 2.5.1.0
Juin 2019
- Ajout d’une nouvelle piste d’événements pour la liaison série :
- édition ASCII, avec options de codes CR/LF, ou hexadécimale des trames de commande série ;
- édition de la couleur et des commentaires des trames de commande série ;
- import et export des trames de commande série dans un fichier serial.txt ;
- export de fichiers Show Control .SC3 avec option d’intégration des trames de commande série ;
- avec l’Event Video Player EVP380, prévisualisation en temps réel des trames de commande série du fichier serial.txt via Art-Net.
- Ajout des options de pistes Contacts de sortie et Liaison série dans la fenêtre Propriétés du projet. Ces options affectent l’affichage des pistes du projet et l’export des fichiers .SC2 et .SC3.
- Ajout de la fonction Coller à la position du curseur — raccourci Ctrl + Maj + V.
- Amélioration de la navigation dans la fenêtre Paramètres Art-Net.
- Correction d’un problème lorsque la Prévisualisation DMX en temps réel est activée pour un port série du menu Interface DMX sans paramètres Art-Net disponibles.
- Correction d’un problème empêchant de copier-coller des événements ayant une position de pas supérieure à 65535.
- Correction de problèmes mineurs.
Show Control Editor 2.5.0.1
Avril 2019
- Correction d’un problème empêchant l’application de démarrer lorsque la configuration Art-Net utilise une interface réseau inexistante ou inutilisable.
- Amélioration de la liste des interfaces réseau dans la fenêtre Paramètres Art-Net:
- signalisation par un code couleur des interfaces réseau non connectées ;
- ajout d’un champ de description des interfaces réseau ;
- correction de l’actualisation de la liste des interfaces réseau.
- Correction de problèmes mineurs.
Show Control Editor 2.5.0.0
Mars 2019
- Ajout de la création de fichiers Show Control .SC3 pour les lecteurs Event Video Player EVP380 — raccourci Ctrl + Maj + B.
- Ajout d’un nouveau moteur de lecture et de décodage audio et vidéo :
- création de projets à partir de fichiers vidéo MP4, MOV ou MKV encodés dans de nombreux formats ;
- prise en charge de types de fichiers audio supplémentaires ;
- prise en charge des fichiers encodés en VBR (Variable Bit Rate) ;
- amélioration de la précision de la durée de la forme d’onde.
- Ajout d’une zone de prévisualisation vidéo dans l’interface principale.
- Ajout de l’option Utiliser une copie de travail audio ou vidéo optimisée pour garantir un positionnement précis des événements et une lecture fluide sur les systèmes à puissance limitée. Modes disponibles : 720p, 480p, 360p, 240p, 144p, Audio et Aucun.
- Ajout de la prise en charge d’Art-Net :
- prévisualisation en temps réel des événements Contacts de sortie et DMX ;
- sélection du réseau utilisé ;
- détection automatique des appareils connectés ;
- sélection des univers attribués aux sources de contrôle de l’appareil et à sa sortie DMX ;
- sélection de l’adresse attribuée à l’appareil.
- Améliorations diverses des informations affichées dans l’interface utilisateur.
- Correction de problèmes mineurs.
Show Control Editor 2.4.0.1
Mai 2018
- Amélioration de la détection automatique de la durée par défaut du projet dans la fenêtre Piste audio et durée du projet.
- Amélioration de la détection des changements dans l’historique Annuler/Refaire après l’ouverture d’un projet dont la durée de référence ou la piste audio est introuvable.
- Correction d’un problème introduit dans la version 2.4.0.0 pouvant corrompre les fichiers projet .ps2 lors de la sauvegarde des changements proposée à la fermeture de l’application.
- Correction d’un problème provoquant l’arrêt de l’application lorsque l’affectation d’une nouvelle durée de référence est annulée après l’ouverture d’un projet dont la durée de référence est introuvable.
- Correction de problèmes mineurs.
Show Control Editor 2.4.0.0
Avril 2018
Édition et sélection des événements
- Remplacement du mode d’édition des événements par un mode d’édition basé sur une zone de sélection :
- sélection sur plusieurs pistes ;
- application des fonctions Supprimer, Couper, Copier et Coller à toute la zone sélectionnée ;
- déplacement de tous les événements sélectionnés par glisser-déposer de l’en-tête de la zone ;
- copie des événements sélectionnés par glisser-déposer avec la touche Ctrl maintenue ;
- application de la fonction Coller à partir du premier pas de la zone sélectionnée ;
- déplacement individuel d’un événement par glisser-déposer ;
- copie d’un événement par glisser-déposer avec Ctrl maintenu ;
- extension de la zone de sélection avec Maj + clic gauche ;
- Ctrl + A et Ctrl + Maj + A permettent respectivement de sélectionner et désélectionner toutes les pistes d’événements du projet ;
- sélection complète d’une piste depuis son menu contextuel ;
- le clic gauche sur une piste d’événements sélectionne le pas désigné ;
- le curseur de lecture est déplacé uniquement par clic gauche sur la piste audio.
- Ajout d’une fonction permettant d’ajouter un événement à l’emplacement du pas sélectionné.
- Ajout de la fonction Insérer un espace vide sur une ou plusieurs pistes depuis le début du projet, la position du curseur, une position désignée sur une piste ou la zone de sélection.
- Ajout de fonctions d’édition des événements permettant d’attribuer une valeur maximale ou minimale, d’augmenter ou diminuer la valeur et de modifier le type de progression des événements sélectionnés.
- Modification de l’édition des propriétés : les changements de valeurs DMX et de type de progression des événements sélectionnés sont appliqués séparément.
- Ajout de préréglages de couleurs personnalisées pour les pistes RGB, enregistrés dans le fichier projet.
Interface et fonctionnement
- Contrôle du zoom du projet avec la molette de la souris lorsque Ctrl est maintenu.
- Ajout de Actualiser la liste des interfaces DMX dans le menu Options.
- Ajout de Restaurer les paramètres par défaut dans le menu Options.
- Amélioration de la prévisualisation DMX en temps réel.
- Amélioration de la restauration des paramètres à l’ouverture de l’application.
- Amélioration de la restauration de l’état du projet après une opération Annuler/Refaire.
- Amélioration de la navigation dans les fenêtres de dialogue.
- Optimisation de la réactivité du programme et de l’utilisation de la mémoire.
- Amélioration et correction des textes, traductions et raccourcis clavier.
- Amélioration des menus contextuels des pistes d’événements, de leurs en-têtes et des zones situées hors des pistes.
- Amélioration de la détection des modifications apportées au projet courant.
- Amélioration de l’installateur : désinstallation automatique de la version précédente et récupération automatique de ses paramètres à partir de la version 2.4.0.0.
- Remplacement du thème d’icônes et des visuels de l’interface, de l’exécutable et des fichiers associés.
- Remplacement du champ Date de création du projet par Date de la dernière modification.
- Empêche l’insertion d’un événement sur la dernière position incomplète du projet lorsque le pas correspondant est inférieur à 50 ms.
- Correction d’un problème de sélection entre Définir manuellement la durée du projet (pas de fichier audio) et Utiliser un fichier audio.
- Correction d’un problème modifiant arbitrairement l’état des événements sélectionnés lors de la sélection d’un composant dans les propriétés des événements.
- Correction d’un problème déclenchant le raccourci Espace lors de l’édition de l’en-tête d’une piste d’événements.
- Correction de problèmes mineurs.
Archives
Show Control Editor 2.3.4.3
Février 2018
- Correction d’un problème introduit dans la version 2.3.4.2 empêchant la sortie DMX en temps réel de fonctionner.
- Correction d’un problème empêchant la sortie DMX en temps réel de réactualiser les canaux des pistes DMX supprimées.
Show Control Editor 2.3.4.2
Janvier 2018
- Amélioration du fonctionnement sous Windows 7, 8, 8.1 et 10.
- Correction de plusieurs problèmes sous ces systèmes :
- affichage correct de l’interface selon la langue sélectionnée ;
- affichage correct de la liste des derniers projets ouverts ;
- restauration correcte des paramètres de configuration au redémarrage.
- Passage de Microsoft .NET Framework 3.0 à Microsoft .NET Framework 4.0.
- Amélioration de l’installateur sous Windows 7, 8, 8.1 et 10.
- Correction de problèmes mineurs.
Show Control Editor 2.3.4.1
Septembre 2014
- Correction d’un problème pouvant provoquer l’arrêt brutal du programme selon la version de .NET Framework installée sous Windows 7 ou Windows 8.
Show Control Editor 2.3.4
Février 2012
- Possibilité de créer un projet en définissant sa durée sans utiliser de fichier audio.
- Possibilité d’ouvrir un projet même lorsque le fichier audio de référence est introuvable.
- Déplacement des événements sélectionnés par glisser-déposer sur une piste ou entre plusieurs pistes.
- Copie des événements sélectionnés par glisser-déposer avec Ctrl maintenu.
- Déplacement par glisser-déposer des périphériques DMX déjà placés dans la zone d’attribution des canaux DMX de la fenêtre Patch.
- Ajout d’une règle temporelle sur la piste audio.
- Ajout de fonctions permettant de modifier l’ordre d’affichage des pistes DMX.
- Ajout de Désélectionner tous les événements (Ctrl + Alt + A) pour la piste sélectionnée.
- Ajout d’options permettant d’afficher le nom du fichier audio (Alt + 4), la règle temporelle (Alt + 5) et les étiquettes des pistes DMX (Alt + 6).
- Ajout de fonctions permettant de réduire ou agrandir une ou toutes les pistes DMX.
- Ajout de raccourcis permettant de sélectionner la piste DMX précédente ou suivante.
- Restauration des options d’affichage lors de la réouverture du programme.
- Améliorations mineures de plusieurs fonctions.
- Correction d’une étape Annuler/Refaire indésirable lorsque l’édition de la fenêtre Patch est annulée.
- Correction de problèmes mineurs.
Show Control Editor 2.3.3
Décembre 2011
- Ajout de Jouer Tout (Ctrl + Maj + Espace) pour démarrer la lecture depuis le début du projet.
- Ajout de boutons pour Aller à la position du curseur et Supprimer événement(s).
- Association d’une icône aux fichiers projet .ps2 et aux fichiers Show Control .sc2.
- Ouverture automatique d’un projet dans Show Control Editor par double-clic sur un fichier .ps2.
- Ajout d’un historique illimité Annuler (Ctrl + Z) / Refaire (Ctrl + Y).
- Possibilité de rouvrir les cinq derniers projets utilisés depuis le menu Fichier.
- Le changement de langue ne nécessite plus de redémarrer le programme.
- Le dernier projet utilisé est automatiquement rouvert au lancement.
- La demande de sauvegarde du projet apparaît uniquement lorsque celui-ci a été modifié.
Show Control Editor 2.3.2
Mai 2011
- Correction d’un problème provoquant l’arrêt du programme sous Windows XP 64 bits, Windows Vista 64 bits ou Windows 7 64 bits.
- Nouveau moteur de lecture audio ne dépendant plus de l’ancien framework DirectSound.
- Mise à jour du moteur de construction de la forme d’onde.
Show Control Editor 2.3.1
Août 2010
- Correction d’un problème pouvant provoquer l’arrêt du programme lors de l’ouverture d’un fichier projet .ps2 créé sur un système d’exploitation utilisant une autre langue.
Show Control Editor 2.3.0
Janvier 2010
- Ajout de la prévisualisation en temps réel des événements DMX via une interface Open DMX USB Enttec.
- Ajout de Sortie DMX en temps réel dans le menu Options.
- Ajout d’un bouton permettant d’activer ou désactiver la sortie DMX en temps réel.
- Ajout du raccourci clavier Alt + R pour activer ou désactiver la sortie DMX en temps réel.
- Ajout de Interface DMX dans le menu Options pour sélectionner le port COM de l’interface USB/DMX Enttec.
- Ajout d’un menu contextuel sur l’en-tête des pistes DMX permettant de choisir parmi neuf couleurs.
- Le clic gauche sur les pistes d’événements change la position du curseur audio ; le clic droit n’a pas d’incidence sur sa position.
- Correction de problèmes mineurs.
Show Control Editor 2.2.0
Juin 2009
- Ajout de liens vers le site ID-AL et le support technique dans le menu Aide.
- Ajout d’un bouton Créer un fichier Show (.sc2).
- Ajout du support multilingue avec détection automatique de la langue système et sélection manuelle. Langues prises en charge : français et anglais.
- Ajout de la sauvegarde des préférences utilisateur.
- Correction de problèmes d’affichage des informations de sélection des événements et en-têtes de pistes.
- Correction d’un problème pouvant générer une erreur lors de la modification des propriétés d’événements.
- Ajout des fonctions de transport Pas suivant, Page suivante, Pas précédent, Page précédente et Aller à la position du curseur.
- Ajout des raccourcis clavier pour les commandes de transport.
- Ajout des raccourcis et du sous-menu de zoom horizontal.
- Amélioration du suivi du curseur lors de l’utilisation du zoom.
- Ajout des informations système dans la fenêtre À propos de Show Control Editor.
- Amélioration de Supprimer événement(s) pour supprimer tous les événements sélectionnés.
- Ajout de Sélectionner tous les événements.
- Ajout de Ajouter un événement à la position du curseur.
- Ajout des fonctions Couper, Copier et Coller entre événements d’une même piste ou de pistes différentes.
- Ajout de fonctions permettant de gérer l’absence, le changement de chemin ou la modification des fichiers audio liés au projet.
- Ajout de Remplacer le fichier audio du projet (Ctrl + Alt + M).
- Ajout d’un détourage coloré indiquant la progression actuellement représentée dans les propriétés d’événements.
- Amélioration de la sélection du composant indiquant la progression affichée.
Show Control Editor 2.1.0
Avril 2009
- Correction d’un nom de fichier potentiellement incorrect sur la forme d’onde lors de l’ouverture d’un projet.
- Ajout de la prise en charge des fichiers audio WAV et MP3 mono.
- Ajout de la prise en charge des débits MP3 32 kbps et 64 kbps.
- Utilisation de fichiers Peaks .pk2 pour accélérer l’ouverture et l’affichage des formes d’onde déjà traitées par l’application.
- Correction d’un problème pouvant empêcher l’affichage du dernier événement d’une piste.
- Ajout d’instructions textuelles dans la fenêtre Patch.
- Ouverture automatique du répertoire Basics lors de la première ouverture de la fenêtre Patch.
- Amélioration de l’ajustement de la grille des pistes selon le niveau de zoom horizontal.
- Ajout d’une grille sur la piste de forme d’onde audio.
- Correction de l’affichage des événements sélectionnés par rapport aux événements non sélectionnés.
- Ajout de la visualisation de la progression des canaux DMX pour les événements Dimmer.
- Ajout de la sélection automatique de la progression affichée selon le Dimmer modifié.
- Ajout du défilement automatique pendant la lecture des fichiers audio, avec possibilité de désactiver le suivi du curseur.
- Ajout d’une confirmation de sauvegarde avant de créer un nouveau projet, d’ouvrir un autre projet ou de quitter le programme.
- Ajout de la visualisation de la progression des sorties relais.
- Ajout d’un composant RGB (Rouge/Vert/Bleu) à la liste des composants DMX.
- Ajout de la visualisation de la progression RGB.
Caractéristiques principales
- Ouverture et sauvegarde des projets .ps2.
- Export .sc2 pour Event Player et Event Player mkII (EP220/EP230).
- Export .sc3 pour Event Video Player (EVP380), avec ou sans trames de commande série intégrées.
- Éditeur de type timeline avec visualisation graphique de la progression des événements.
- Jusqu’à 512 pistes DMX.
- Piste Contacts de sortie optionnelle.
- Piste Liaison série optionnelle pour l’Event Video Player EVP380.
- Jusqu’à 2 heures de projet.
- Résolution des pas : 50 ms.
- Synchronisation des événements avec des fichiers MP3, WAV, MP4, MOV ou MKV à l’aide de la forme d’onde et de la prévisualisation vidéo en temps réel.
- Création de projets sans fichier audio ou vidéo.
- Édition à la souris avec sélection et glisser-déposer des événements, ainsi qu’édition graphique des propriétés pour les gradateurs, RGB, contacts de sortie et trames de commande série.
- Prévisualisation DMX en temps réel via une interface USB-vers-DMX prise en charge — Open DMX USB Enttec ou Event Player mkII (EP230) — ou une interface Art-Net générique ou Event Video Player EVP380.
- Langues prises en charge : français et anglais.
Configuration requise
- Microsoft Windows XP SP3 ou supérieur, Windows Vista, Windows 7, Windows 8, Windows 8.1 ou Windows 10 — 32 ou 64 bits.
- Processeur Intel ou AMD 1 GHz ou supérieur.
- 1 Go de RAM ; 2 Go ou plus recommandés avec Windows Vista, 7, 8, 8.1 ou 10.
- 160 Mo d’espace disque pour l’installation.
- Carte graphique compatible XVGA (1024 × 768) ou supérieure. Décodage vidéo matériel recommandé pour les utilisations vidéo.
- Microsoft .NET Framework 4.0 ou supérieur.
- Optionnel avec l’Event Player ou l’Event Player mkII - EP220 : interface Open DMX USB Enttec pour la prévisualisation en temps réel des événements DMX.
Installation
L’utilitaire d’installation crée les répertoires nécessaires et copie les fichiers requis par Show Control Editor sur l’ordinateur.
- Téléchargez l’utilitaire d’installation de Show Control Editor.
- Double-cliquez sur le fichier téléchargé.
- Suivez les instructions affichées pour installer la version adaptée à votre ordinateur.
Problèmes connus
- La lecture de fichiers vidéo dont la taille, par exemple 4K, ou l’encodage, par exemple H.265, n’est pas pris en charge matériellement par la carte graphique ou le système peut provoquer un problème. Dans ce cas, utilisez l’option Utiliser une copie de travail audio ou vidéo optimisée.
- Sous Microsoft Windows XP et Windows Vista, l’application ne démarre pas correctement si Microsoft .NET Framework 4.0 ou supérieur n’est pas installé.
Cet article a-t-il été utile ?
C'est super !
Merci pour votre commentaire
Désolé ! Nous n'avons pas pu vous être utile
Merci pour votre commentaire
Commentaires envoyés
Nous apprécions vos efforts et nous allons corriger l'article